Text to Give and #GivingTuesday giving pages experiencing issues
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 17:51 UTC
Identified
The Text to Give and #GivingTuesday giving pages have been experiencing technical difficulties and may not respond. Please know we are working diligently to resolve this.
To give directly:
Orphan's Promise https://www.orphanspromise.org/givingtuesday2020/
Operation Blessing: https://go.ob.org/GTFB
CBN: https://www.cbn.com/giving/700club/contribute.aspx?intcmp=gvsl_www1.cbn.com-_11_GiveToCBN&o=2
Posted Dec 01, 2020 - 15:54 UTC
This incident affected: Donation Processing.