Text to Give sites experiencing issues
Resolved
This incident has been resolved.
Posted Dec 02, 2020 - 12:24 UTC
Identified
CBN is experiencing periodic issues with our Text 2 Give platform which may impact some Giving Tuesday options. Please either visit our website directly or call 800-700-7000 to make a donation.
Posted Dec 01, 2020 - 20:09 UTC
This incident affected: Donation Processing.