Technical issues with phone
Resolved
This incident has been resolved.
Posted Mar 23, 2022 - 19:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2022 - 17:26 UTC
Identified
We are currently experiencing technical issues and we are working hard to resolve. Please try your call again later.

If you are calling for prayer, you can visit CBN.com to submit your prayer request, or you can download the MyCBN app to your phone or tablet and join in the prayer discussion and enjoy other CBN devotionals. To donate, you can visit CBN.com or text CBN to 71777.
Posted Mar 23, 2022 - 16:45 UTC
This incident affected: CBN Communications (Prayer Center).