Testing Teams integration
Postmortem

There were problems. We fixed them.

Posted Apr 17, 2020 - 12:37 UTC

Resolved
We finally fixed everything.
Posted Apr 17, 2020 - 12:36 UTC
Investigating
Everything is broken!
Posted Apr 17, 2020 - 01:55 UTC